Back to overview
Resolved

PixelGit service degredation

Aug 22, 2026 at 12:37am UTC
Affected services
PixelGit

Resolved
Aug 22, 2026 at 12:37am UTC

PixelGit is currently dealing with a large DDOS attack, which has triggered additional DDOS prevention measures. Some legitimate users may be affected by these measures temporarily whilst we wait for the attack to subside. We are working to ensure minimal disruption, but we do expect some temporarily.

If you are having issues accessing PixelGit please contact us by visiting https://support.pixelset.dev

Apologies for any inconvenience caused!